Home Forums WooCommerce Plugins Dynamic Gallery WooCommerce Dynamic Gallery PRO and PHP 7 Support

WooCommerce Dynamic Gallery PRO and PHP 7 Support

This topic contains 2 replies, has 2 voices, and was last updated by  Steve Truman 2 months, 1 week ago.

Bug Report
PATCH RELEASED
  • Author
    Posts
  • #8282683

    Scott
    Spectator

    Hi I am looking at upgrading my site to PHP 7 and ran a plugin that tests my current site for potential compatibility issues. It is throwing this error message. Can you let me know if you think the error is valid and if the plugin has been tested with PHP 7.

    FILE: /home/…./public_html/LIVE/wp-content/plugins/woocommerce-dynamic-gallery-pro/admin/admin-interface.php
    ——————————————————————————————————————
    FOUND 2 ERRORS AFFECTING 2 LINES
    ——————————————————————————————————————
    402 | ERROR | Global with variable variables is not allowed since PHP 7.0
    441 | ERROR | Global with variable variables is not allowed since PHP 7.0
    ——————————————————————————————————————

  • #8282684

    Steve Truman
    Keymaster

    Hi Scott,

    All of our software is fully PHP 7 compatible. a3rev.com has been running on PHP 7 since September 2016 – WooComnerce Dynamic Gallery is on every product page on this site.

    Also all of our website client sites are running on PHP 7.0 with WC Dynamic Gallery on the e-commerce sites and there are no issues – see showcase https://a3rev.com/portfolios/

    Will check Dynamic Gallery again today to see if can replicate those errors you are seeing – they may be an issue or maybe a false positive from the plugin you are using to test.

    If we can relocate will fix and push a patch.

    Will let you know

    Happy New Year
    Steve

  • #8282766

    Steve Truman
    Keymaster

    Hi Scott,

    Have checked that and see that the issue is from the a3rev Plugin Framework that all of our plugins are built on. We have just put out a patch for that along with some other minor tweaks and have tested for full compatibility with latest version of WordPress and WooCommerce.

    Below is a copy of the changelog – you will see where we have credited you for reporting the PHP 7.0 issue – thank you.

    = 2.4.3 – 2017/01/13 =
    * Tweak – Change global $$variable to global ${$variable} for compatibility with PHP 7.0
    * Tweak – Removed auto redirect to plugins admin panel on activation
    * Tweak – Update a3 Revolution to a3rev Software on plugins description
    * Tweak – Added Settings link to plugins description on plugins menu
    * Tweak – Tested for full compatibility with WordPress version 4.7.1
    * Tweak – Tested for full compatibility with WooCommerce version 2.6.12
    * Credit – Thanks to Scott for reporting the PHP 7.0 Global variable error

    Regards
    Steve

The topic ‘WooCommerce Dynamic Gallery PRO and PHP 7 Support’ is closed to new replies.